PHP İnternet Explorer tarayıcısını yakalamak

Biz geliştiriciler ie tarayıcısını genel olarak pek sevmeyiz.

Bunun nedeni ie tarayıcısının uyum sorunlarıdır. Genelde kulandığınız eklentiler ie 9 ve altındaki tarayıcılarda patlayacaktır. Bir kullanıcı sitenize girdiğinde bozun bir site görmeindense siteyi hiç görmemesi ve tarayıcısını yükseltevileceği bir sayfaya yönlendirmeyi tercih ederiz. Durum böyle olunca gelen kullanıcının ie 9 ve altındaki bir tarayıcı ile gelip gelmediğini kontrol etmemiz gerekir. 

//Tarayıcı Uyumluluğu Kontrol Başla
if(preg_match('/(?i)msie [5-9]/',$_SERVER['HTTP_USER_AGENT']))
{
    header('Location: http://browser_error/support.html');
    exit();
}
//Tarayıcı Uyumluluğu Kontrol Bit

vermiş olduğum bu kod sitenize gelen kullanıcıları istediğiniz adrese yönlendirmenizi sağlayacaktır. Yönlendireceğiniz sayfada kullanıcının tarayıcısını güncelleyebileceği bir ekran yaparsanız büyük hayır duaları alırsınız 😀